Submit a request

How Can We Help?

Where can I find the v2 (32-bit only) plugin versions?

The legacy 32-bit only v2 plugin versions will only work in DAW/Host software versions supporting 32-bit plug-ins.

If the host software is no longer supporting 32-bits, the v2 versions will not be compatible and can’t be used with the DAW/Host anymore.

If you are still running a DAW/Host supporting 32-bit plugin versions, and are looking for the v2 version installers, they can be downloaded here.

Legacy Download Archives

Was this article helpful?
How can we improve this article?
Please submit the reason for your vote so that we can improve the article.
Previous How To update my installed software to the latest version?
Table of Contents